OBS Twitch suggestions needed

So while trying to stream Shadowrun Returns yesterday I discovered how inadequate my computer really is. I thought if I ran with low enough settings I could manage to produce a watchable product however that wasn't the case. My PC stats are as follows:

CPU: Pentium Dual Core G630 @2.70GHz
RAM: 4 GB
Graphics: NVidia GTS 250
Motherboard: PC Chips A15G

Here are some of my OBS Settings as shown from the log:

09:13:14.046: video settings reset:
09:13:14.046:  base resolution:   1920x1080
09:13:14.046:  output resolution: 768x432
09:13:14.046:  fps:               25/1
09:13:14.046:  format:            NV12
09:13:14.052: Settings changed (outputs, video)

09:15:31.033: [x264 encoder: 'streaming_h264'] preset: veryfast
09:15:31.033: [x264 encoder: 'streaming_h264'] profile: main
09:15:31.033: [x264 encoder: 'streaming_h264'] settings:
09:15:31.033:  bitrate:     1500
09:15:31.033:  buffer size: 1500
09:15:31.033:  crf:         0 (0 when CBR is enabled)
09:15:31.033:  fps_num:     25
09:15:31.033:  fps_den:     1
09:15:31.033:  width:       768
09:15:31.033:  height:      432
09:15:31.033:  keyint:      50
09:15:31.033:  vfr:         off
09:15:31.033:  cbr:         on
09:15:31.033: [x264 encoder: 'streaming_h264'] custom settings: scenecut=0
09:15:31.040: [Media Foundation AAC: 'Track1']: encoder created
09:15:31.040:  bitrate: 128
09:15:31.040:  channels: 2
09:15:31.040:  sample rate: 44100
09:15:31.040:  bits-per-sample: 16

With Shadowrun Returns I was running at 640x360 but still having serious issues. My encoder almost always was overloaded. I changed the FPS to 25 from 30 after a suggestion from the OBS setting recommender. Also my bitrate I set to 1500 and matched buffer size after reading a little bit on the OBS forums. I'm playing more turn based games so a lower bitrate will not impair the quality. While testing Shining Force with the settings above the recording was passable although it still had:

09:27:21.431: Output 'adv_file_output': Number of skipped frames due to encoding lag: 2399 (13.5%)
09:27:21.431: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 392 (2.2%)

I would really appreciate any pointers on something I may be missing to get a passable stream going.

Comments

Popular Posts